Technical requirements

Before your online class starts, test out your technology and make sure you have up to date software.
Here are our recommendations to get your started.

Browser Windows Mac OS Audio and video
Make sure you have the latest version of Chrome, Safari, Firefox or Edge browser installed on your computer, laptop or other device.

browsers.jpg

Please be aware that Internet Explorer does not support Google Meet.

Need more help?

For more information or to get help accessing your student IT account, complete our online form.
Contact Us Form
 

Was this article helpful?
2 out of 2 found this helpful